ScopeHost - Inbound Filtering Delay - Mailchannels – Incident details

Inbound Filtering Delay - Mailchannels

Resolved
Degraded performance
Started about 1 month agoLasted about 5 hours

Affected

SMTP - Outbound

Operational from 10:42 AM to 3:43 PM

Updates
  • Resolved
    Update

    Issue resolved.

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    MailChannels is facing Inbound Filtering delays and it is affecting SMTP service. We are currently investigating this incident.